RESOLVED: We're investigating a potential issue with creating new Wix Sites and Accounts.
Incident Report for Wix
Resolved
This issue is now resolved. We thank you for your patience and understanding as we worked to resolve this issue.
Posted Jun 07, 2022 - 18:28 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jun 07, 2022 - 18:04 UTC
Investigating
Our engineers are currently investigating an issue affecting creating a new Site or Wix Account. Check back here for updates.
Posted Jun 07, 2022 - 17:42 UTC
This incident affected: Site Dashboard (My Sites) and Site Editing (Sign-In).