Issue with PayPal Checkout
Incident Report for Wix Status Page
Resolved
This issue is now resolved. We thank you for your patience and understanding as we worked to resolve this issue.
Posted Apr 08, 2021 - 18:06 UTC
Investigating
Some website visitors who try to checkout with PayPal may experience issues when connecting to PayPal. There is currently a service disruption on PayPal's end that they are investigating.

PayPal Status Page - https://www.paypal-status.com/product/production
Posted Apr 08, 2021 - 17:37 UTC
This incident affected: Payments (Third-Party Payment Providers).