RESOLVED: Major Issue affecting multiple services
Incident Report for Wix Status Page
Resolved
This incident has been resolved.
Posted Nov 11, 2021 - 13:41 UTC
Investigating
Some site visitors may experience issues on multiple services.
Posted Nov 11, 2021 - 13:23 UTC
This incident affected: Site Loading (Site Loading).