Multiple Issues With Premium Wix Services
Incident Report for Wix
Resolved
This incident has been resolved.
Posted Dec 06, 2023 - 17:53 UTC
Identified
The issue has been identified and our engineers are working out the best solution for the problem.
Posted Dec 06, 2023 - 15:28 UTC
This incident affected: Premium Services (Purchase Premium Plan).