RESOLVED: Multiple issues across Wix services

Incident Report for Wix

Resolved

RESOLVED: The incident has been resolved.
Posted Jul 02, 2025 - 12:11 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jul 02, 2025 - 11:57 UTC

Update

We are continuing to work on a fix for this issue.
Posted Jul 02, 2025 - 11:47 UTC

Update

We are continuing to work on a fix for this issue.
Posted Jul 02, 2025 - 11:45 UTC

Identified

The issue has been identified, and a fix is now being implemented.
Posted Jul 02, 2025 - 11:31 UTC

Investigating

We are currently investigating this issue.
Posted Jul 02, 2025 - 11:29 UTC
This incident affected: Site Editing (Sign-In, Wix Editor).