RESOLVED: We're investigating a potential issue with some live sites not loading
Incident Report for Wix
Resolved
Incident has been resolved.
Posted Aug 28, 2024 - 17:53 UTC
Monitoring
A fix has been released, and we are monitoring the results
Posted Aug 28, 2024 - 17:41 UTC
Update
We are continuing to investigate the issue.
Posted Aug 28, 2024 - 17:28 UTC
Investigating
Our engineers are currently investigating an issue affecting some live sites not loading. Check back here for updates.
Posted Aug 28, 2024 - 16:18 UTC
This incident affected: Site Loading (Site Loading).