RESOLVED: We're investigating a potential issue with sites unable to load.

Incident Report for Wix

Resolved

This incident has been resolved.
Posted Mar 16, 2026 - 16:09 UTC

Identified

The issue has been identified, implementing the fix.
Posted Mar 16, 2026 - 15:46 UTC
This incident affected: Site Loading (Site Loading).