RESOLVED: Wix.com Loading Intermittently
Incident Report for Wix
Resolved
The incident has been resolved.
Posted Jan 05, 2024 - 13:34 UTC
Investigating
We are currently investigating this issue.
Posted Jan 05, 2024 - 13:29 UTC
This incident affected: Site Dashboard (My Sites) and Site Loading (Site Loading).