RESOLVED: Our Customer Care is temporarily unavailable
Incident Report for Wix
Resolved
This incident has been resolved.
Posted Feb 14, 2024 - 07:35 UTC
Investigating
This incident has been resolved. We thank you for your patience and understanding as we worked to resolve this issue.
Posted Feb 14, 2024 - 03:07 UTC
This incident affected: Customer Care (Chatbot).