Resolved: Issues Accepting Payments with Wix Payments Service.

Incident Report for Wix

Resolved

This incident has been resolved.
Posted Apr 21, 2025 - 17:49 UTC

Monitoring

Fix has been implemented on Adyen's side, and we are monitoring the results to ensure the stability of our service
Posted Apr 21, 2025 - 17:48 UTC

Identified

Our engineers identified that this issue affecting only specific Wix Payments merchants that were onboarded with Adyen company
Posted Apr 21, 2025 - 17:39 UTC

Investigating

Our engineers are currently investigating an issue affecting payments. Check back here for updates.
Posted Apr 21, 2025 - 17:21 UTC
This incident affected: Payments (Wix Payments).