RESOLVED: An Issue for Some Users with Accessing Their Dashboards

Incident Report for Wix

Resolved

This incident has been mitigated.

We are conducting an additional investigation on the cause and will update in the Postmortem once our investigation is complete. Thank you for your patience.
Posted Mar 25, 2026 - 17:16 UTC

Investigating

We are aware that some users are experiencing issues with accessing their Dashboard and are currently investigating it
Posted Mar 25, 2026 - 16:15 UTC
This incident affected: Site Dashboard (My Sites).