RESOLVED: Live Site Images and Media Upload Manager Partially Affected Due to Google Cloud Outage

Incident Report for Wix

Resolved

Google Cloud issues are fully resolved.

Please refer to Google Cloud Status Page for additional information: https://status.cloud.google.com/incidents/ow5i3PPK96RduMcb1SsW
Posted Jun 12, 2025 - 20:54 UTC

Update

Issue is related to Google Cloud Outage. Please refer to Google Cloud Status Page for additional information: https://status.cloud.google.com/
Posted Jun 12, 2025 - 20:42 UTC

Update

Issue is related to Google Cloud Outage. Please refer to Google Cloud Status Page for additional information: https://status.cloud.google.com/
Posted Jun 12, 2025 - 20:04 UTC

Update

We are continuing to monitor for any further issues.
Posted Jun 12, 2025 - 20:04 UTC

Update

Issue is related to Google Cloud Outage. Please refer to Google Cloud Status Page for additional information: https://status.cloud.google.com/
Posted Jun 12, 2025 - 19:15 UTC

Monitoring

Issue is related to Google Cloud Outage. Please refer to Google Cloud Status Page for additional information: https://status.cloud.google.com/
Posted Jun 12, 2025 - 19:11 UTC

Update

Please refer to Google Cloud Status Page for additional information: https://status.cloud.google.com/
Posted Jun 12, 2025 - 18:48 UTC

Identified

Issue is related to Google Cloud Outage. Please refer to Google Cloud Status Page for additional information: https://status.cloud.google.com/
Posted Jun 12, 2025 - 18:29 UTC
This incident affected: Media (Download, Upload).