RESOLVED: Issue affecting multiple services

Incident Report for Wix

Resolved

This incident has been resolved.
Posted Jul 02, 2025 - 08:02 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jul 02, 2025 - 07:54 UTC

Investigating

Some site visitors may experience issues on multiple services.
Posted Jul 02, 2025 - 07:49 UTC
This incident affected: Site Dashboard (My Sites), Bookings (Make a Booking), Customer Care (Chatbot), and Stores (Checkout).