RESOLVED: We're investigating a potential issue with Wix live sites loading
Incident Report for Wix
Resolved
This incident has been resolved.
Posted Jun 29, 2023 - 16:47 UTC
Update
Publishing sites has been reenabled.

Our engineers are still investigating the issue with live sites loading. Thank you for your continued patience.
Posted Jun 29, 2023 - 15:57 UTC
Update
We are continuing to investigate this issue.
Posted Jun 29, 2023 - 15:38 UTC
Update
We are continuing to investigate this issue. Publishing live sites has been temporarily disabled.
Posted Jun 29, 2023 - 14:57 UTC
Investigating
Our engineers are currently investigating an issue affecting Wix live sites loading
Posted Jun 29, 2023 - 11:52 UTC
This incident affected: Site Loading (Site Loading).