Issue affecting multiple services
Incident Report for Wix
Resolved
This incident has been resolved.
Posted Jun 19, 2022 - 16:46 UTC
Investigating
Our engineers are investigating issues impacting multiple Wix services.
Come back here for updates.
Posted Jun 19, 2022 - 15:36 UTC
This incident affected: Site Loading (Site Loading) and Site Editing (Wix Editor).