RESOLVED: Major Issue with Dashboard & Site editing
Incident Report for Wix Status Page
Resolved
This incident has been resolved.
Posted Jul 27, 2021 - 15:21 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jul 27, 2021 - 15:14 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Jul 27, 2021 - 15:06 UTC
Investigating
Some website owners may experience issues when trying to access or edit their sites.
Posted Jul 27, 2021 - 14:51 UTC
This incident affected: Site Dashboard (My Sites) and Site Editing (Wix Editor, ADI Editor, Editor X).