Minor issue with domain related actions
Incident Report for Wix Status Page
Resolved
This incident has been resolved.
Posted Feb 27, 2021 - 09:41 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Feb 27, 2021 - 09:15 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Feb 27, 2021 - 08:42 UTC
Investigating
Some website owners may experience issues when trying to purchase, connect or transfer a domain.
Posted Feb 26, 2021 - 23:38 UTC
This incident affected: Premium Services (Connect Domain).