RESOLVED: Issues With Checkout Flow for Multiple Services and Payment Services.

Incident Report for Wix

Resolved

This incident has been resolved.
Posted 5 days ago. Apr 04, 2025 - 08:19 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted 5 days ago. Apr 04, 2025 - 08:05 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted 5 days ago. Apr 04, 2025 - 07:59 UTC

Update

We are continuing to investigate this issue.
Posted 5 days ago. Apr 04, 2025 - 07:38 UTC

Investigating

Our engineers are currently investigating an issue affecting checkout flow for multiple services.
Check back here for updates.
Posted 5 days ago. Apr 04, 2025 - 07:22 UTC
This incident affected: Payments (Wix Payments, Third-Party Payment Providers) and Stores (Checkout).