RESOLVED: PayPal Payments Processing Issue

Incident Report for Wix

Resolved

Issue with PayPal Payments Processing is resolved on PayPal side.
Please refer to PayPal Status Page for additional information: https://www.paypal-status.com/incident/production
Posted Aug 01, 2025 - 14:05 UTC

Monitoring

We're seeing a decrease of complaints regarding PayPal Payments Processing due to a technical issue on PayPal side.

In case you still experience issues, please refer to PayPal for additional information: https://www.paypal-status.com/incident/production
Posted Aug 01, 2025 - 13:16 UTC

Update

We've identified that issues with PayPal Payments Processing is due to a technical issue on PayPal side.

Please refer to PayPal for additional information: https://www.paypal-status.com/incident/production
Posted Aug 01, 2025 - 12:58 UTC

Identified

We've identified that issues with PayPal Payments Processing is due to a technical issue on PayPal side.
Posted Aug 01, 2025 - 12:46 UTC
This incident affected: Payments (Third-Party Payment Providers).