RESOLVED: Issues Accepting Payments with PayPal

Incident Report for Wix

Resolved

This incident has been resolved.
Posted 22 days ago. Apr 08, 2025 - 21:29 UTC

Monitoring

A fix has been implemented from PayPal side, and we are monitoring the results. Paypal payment provider is back open, but there may still be some issues.
Posted 22 days ago. Apr 08, 2025 - 21:26 UTC

Identified

We have identified that the issue is on PayPal side, and have closed the option to checkout using PayPal while they work to resolve it.
Posted 22 days ago. Apr 08, 2025 - 21:14 UTC

Investigating

Some users may be experiencing issues accepting payments with PayPal Payment providers. We are aware of this issue and investigating.
Posted 22 days ago. Apr 08, 2025 - 20:37 UTC
This incident affected: Payments (Third-Party Payment Providers).