Wix system status

Real-time health for Wix products and services

Track current availability, recent incidents, and service updates across the Wix platform.

Report a problem with Wix

Need help right away? Visit support.wix.com. Some issues affecting a small number of users may not appear here immediately.

RESOLVED: Some Users Have Issues with Saving/Publishing Sites

Incident Report for Wix

Resolved

This incident has been resolved.
Posted May 07, 2026 - 21:51 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted May 07, 2026 - 18:12 UTC

Update

Our engineers identified an issue caused by a corrupted version of the editor. This version has already been reverted, but users who attempted to publish their sites while it was active may still be affected. We are still actively working on a fix.
Posted May 07, 2026 - 17:44 UTC

Update

The issue has been identified, and a fix is being deployed.
Posted May 07, 2026 - 15:57 UTC

Update

Our engineers identified an issue caused by a corrupted version of the editor. This version has already been reverted, but users who attempted to publish their sites while it was active may still be affected. We are still actively working on a fix.
Posted May 07, 2026 - 13:55 UTC

Update

Our engineers identified an issue caused by a corrupted version of the editor. This version has already been reverted, but users who attempted to publish their sites while it was active may still be affected. We are actively working on a fix.
Posted May 07, 2026 - 12:23 UTC

Update

The issue has been identified and a fix is being implemented.
Posted May 07, 2026 - 12:06 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted May 07, 2026 - 11:59 UTC

Update

We are continuing to investigate this issue.
Posted May 07, 2026 - 11:56 UTC

Investigating

We are currently investigating this issue.
Posted May 07, 2026 - 11:36 UTC
This incident affected: Site Editing (Wix Editor, Wix Studio).