RESOLVED: Issues adding and managing media to site

Incident Report for Wix

Resolved

The incident has been resolved.
Posted Nov 03, 2025 - 12:16 UTC

Identified

The issue has been identified and a fix is currently being implemented.
Posted Nov 03, 2025 - 12:08 UTC

Investigating

We are currently investigating an issue adding and managing media files to sites.
Posted Nov 03, 2025 - 12:05 UTC
This incident affected: Media (Upload).