RESOLVED: We're investigating a potential issue accessing some Premium services
Incident Report for Wix Status Page
Resolved
This incident has been resolved.
Posted Sep 13, 2021 - 14:11 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Sep 13, 2021 - 14:08 UTC
Investigating
Our engineers are currently investigating an issue affecting Domains & Mailboxes flows.
Check back here for updates.
Posted Sep 13, 2021 - 13:53 UTC
This incident affected: Premium Services (Connect Domain, Connect Mailbox).