RESOLVED: Some Live Sites Loading Blank
Incident Report for Wix
Resolved
This incident has been resolved.

Some Wix live sites experienced issues loading or displayed a blank white screen due to a failure in our internal cache layer in one of our regions.
Unfortunately, Wix's automatic traffic switchover mechanism did not function as expected, leading to a delay in resolution.
The issue was ultimately resolved by redirecting traffic to an alternate region.

We have fixed the automatic failover mechanism and enhanced our internal operational runbooks to better address such incidents in the future.
Posted Jan 09, 2025 - 06:30 UTC
Update
We appreciate your patience as our engineers continue to work on the issue.
Posted Jan 09, 2025 - 03:52 UTC
Investigating
Our engineers are currently investigating an issue affecting live sites not loading
Posted Jan 09, 2025 - 02:56 UTC
This incident affected: Site Loading (Site Loading).