RESOLVED: We're investigating a potential issue with site dashboard.
Incident Report for Wix
Resolved
This incident has been resolved.
Posted Jan 08, 2025 - 14:06 UTC
Investigating
Our engineers are currently investigating an issue affecting site dashboard. Check back here for updates.
Posted Jan 08, 2025 - 13:14 UTC
This incident affected: Site Dashboard (My Sites).