RESOLVED: Unable to Load Website Dashboard

Incident Report for Wix

Resolved

The incident has now been resolved. We thank you for your patience.
Posted Jun 10, 2025 - 11:40 UTC

Monitoring

A fix has been implemented and we are currently monitoring the results.
Posted Jun 10, 2025 - 11:34 UTC

Investigating

We are currently investigating an issue with loading the website dashboard.
Posted Jun 10, 2025 - 11:29 UTC
This incident affected: Site Dashboard (My Sites).