RESOLVED: Major issue with Instagram feed not loading on live sites
Incident Report for Wix
Resolved
This incident has been resolved.
Posted Nov 21, 2023 - 10:22 UTC
Investigating
Our engineers are currently investigating issues with Instagram feed not loading on live sites.
Check back here for updates.
Posted Nov 21, 2023 - 05:47 UTC