Wix system status

Real-time health for Wix products and services

Track current availability, recent incidents, and service updates across the Wix platform.

Report a problem with Wix

Need help right away? Visit support.wix.com. Some issues affecting a small number of users may not appear here immediately.

RESOLVED: SMS Delivery Delays on Twilio Side

Incident Report for Wix

Resolved

Issue with SMS Delivery Delays on Twilio side is resolved, and is no longer impacting Wix services.

Please refer to Twilio Status Page for additional information: https://status.twilio.com/
Posted Sep 01, 2026 - 14:55 UTC

Update

We're seeing a decreased number of issues with SMS Deliverability that are related to incident on Twilio side.
In case you still experience issues, please refer to Twilio for additional information: https://status.twilio.com/
Posted Sep 01, 2026 - 11:07 UTC

Monitoring

We're seeing a decreased number of issues with SMS Deliverability that are related to incident on Twilio side.
In case you still experience issues, please refer to Twilio for additional information: https://status.twilio.com/
Posted Sep 01, 2026 - 10:38 UTC

Identified

We've identified that issues with SMS Deliverability are related to incident on Twilio side.

Please refer to Twilio for additional information: https://status.twilio.com/
Posted Sep 01, 2026 - 09:10 UTC
This incident affected: Marketing Tools (Email Marketing), Customer Management Tools (Automations, Business Phone Number, Subscriber Registration), and Site Editing (Sign-In).